Регистры накопления 1С

Регистр накопления 1С это структурированный набор данных, в котором находится информация о всех движения (приход / расход или обороты) выбранных документов.


Оглавление


Виды регистра накопления

В 1С бывает только два вида регистра накопления:

  • Обороты
    Если планируется получать по регистру только обороты, обязательно устанавливайте вид обороты.
    Например, при регистрации продаж нам важно количество продаж и остатки здесь абсолютно не нужны. Следовательно, вид регистра нужно установить «Обороты».
  • Остатки
    Если планируется получать по регистру остатки и обороты, устанавливайте вид остатки. Например возьмем регистр накопления «ТоварыНаСкладах» в нем важной информацией будет как остатки, так и обороты. Следовательно, вид регистра нужно установить «Остатки».

Внимание: не правильный выбор вида регистра накопления повлечет низкую производительность информационной базы.


Измерения, Ресурсы, Реквизиты и Стандартные реквизиты

В любом регистре накопления присутствуют измерения, ресурсы, реквизиты и стандартные реквизиты.

Регистр накопления - данные

Измерения нужны для формирования ключевых данных записи, по которым в будущем можно получить остатки или посмотреть оборот по интересующим Вас измерениям.
Так же в свойствах измерения можно установить проверку заполнения измерения (при пустом значении будет вызвана ошибка)

Ресурсы нужны для хранения суммовых данных в регистре: количество, сумма и т.д. Ресурсы в будущем будем получать по измерениям.

Реквизиты в основном нужны для хранения сопутствующей информации и редко используются.

Стандартные реквизиты бывают следующими:

  • период — дата, когда выполнилось движение по регистру
  • регистратор — документ, при помощи которого была выполнена запись в регистре
  • вид движения — приход или расход (приход увеличивает количество ресурсов, а расход уменьшает)


Регистраторы

Регистраторы это документы, которые могут делать движения в регистре накопления. Движения в регистр накопления 1С можно делать только по средство документов (регистраторов). Большинство алгоритмов, создания движения в регистре накопления, формируются при проведении документа в модуле объекта, процедура «ОбработкаПроведения».

Регистр накопления - регистраторы


Индексация измерений

Индексация требуется для увеличения производительности информационной базы.
Свойство «Индексировать» требуется указать у измерений, по которым планируется выполнять многократно отбор и у которых большое количество элементов.

Регистр накопления - индексайия

Для примера: регистр накопления «ПартииТоваровНаСкладах». Есть измерение «Номенклатура» и «СтутусПартии». Целесообразней установить признак индексации у измерения «Номенклатура», чем у «СтутусПартии», так как количество вариантов номенклатуры гораздо выше, чем у статуса партии.


Уникальность записей

1С Предприятие контролирует уникальность записей в регистре накопления, и по этому, вы не встретите двух одинаковых записей.

Возможности регистра накопления

  • выборка записей за определенный период по заданным измерениям
  • выборка записей по регистратору
  • получение остатков и оборотов на выбранную дату с заданными измерениями
  • вычисление итогов на указанную дату


Примеры работы с регистром накопления

Пример получения остатков на текущую дату

Процедура ПолучитьОстатокНаДату()
НовЗапрос = Новый Запрос;
НовЗапрос.Текст =
"ВЫБРАТЬ
| ТовОстатки.Номенклатура,
| ТовОстатки.КоличествоОстаток
|ИЗ
| РегистрНакопления.ТоварыНаСкладах.Остатки(&ТекДата, ) КАК ТовОстатки";
НовЗапрос.УстановитьПараметр("ТекДата", ТекущаяДата());
ВыборкаЗапроса = НовЗапрос.Выполнить().Выбрать();
Пока ВыборкаЗапроса.Следующий() Цикл
КонецЦикла;
КонецПроцедуры

Пример получения оборотов за текущий год

НовЗапрос = Новый Запрос;
НовЗапрос.Текст =
"ВЫБРАТЬ
| ТовОбороты.Номенклатура,
| ТовОбороты.КоличествоОборот
|ИЗ
| РегистрНакопления.ТоварыНаСкладах.Обороты(&НачПериода, &КонПериода, , ) КАК ТовОбороты";

НовЗапрос.УстановитьПараметр("НачПериода", НачалоГода(ТекущаяДата()));
НовЗапрос.УстановитьПараметр("КонПериода", ТекущаяДата());

ВыборкаЗапроса = НовЗапрос.Выполнить().Выбрать();

Пока ВыборкаЗапроса.Следующий() Цикл
КонецЦикла;

Пример как выбрать движения в регистре накопления

НовЗапрос = Новый Запрос;
НовЗапрос.Текст =
"ВЫБРАТЬ
| ТоварыНаСкладах.Период,
| ТоварыНаСкладах.Регистратор,
| ТоварыНаСкладах.ВидДвижения,
| ТоварыНаСкладах.Номенклатура,
| ТоварыНаСкладах.Количество
|ИЗ
| РегистрНакопления.ТоварыНаСкладах КАК ТоварыНаСкладах";

ВыборкаЗапроса = НовЗапрос.Выполнить().Выбрать();

Пока ВыборкаЗапроса.Следующий() Цикл
КонецЦикла;


Формы списка регистра накопления

Формы используются для визуального просмотра всех движений выбранного регистра. В ней можно посмотреть какие документы делают расход или приход, а также посмотреть по каким измерениям. Также там можно отсортировать движения или сделать отбор.
Система автоматически сможет сформировать форму списка или Вы сами можете настроить ее.

Добавить комментарий

Имя